Linux下无法正常安装(升级)和删除Nodejs的解决方法

Linux(CentOS6)下安装Nodejs,删除Nodejs,升级Nodejs遇到的一些问题,以及相关解决方案的介绍

接着上次说,自从买了VPS后就没闲着,总想要充分利用起来倒腾点东西。于是决定安装nodejs搭建web服务器等,如今nodejs稳定版本已经更新到8.x了,因此我就试着装一下8.x吧,没想到又遇到了坑,一搞搞了好几天。

我的操作系统是CentOS 6 64 Bit的,我查阅了Nodejs官方升级文档(包含各种可支持的系统),针对我的系统需要分别执行以下几条命令:

curl --silent --location https://rpm.nodesource.com/setup_8.x | sudo bash -
sudo yum -y install nodejs

当然你也许需要通过以下命令额外安装构建工具:

sudo yum install gcc-c++ make
# or: sudo yum groupinstall 'Development Tools'

如果其他系统则可以参考文档中其他内容。

在这里我就遇到坑了(可能存在该情况较少,所以稍后具体解决放在文章最后来说)。上面第一条应该是静默指定使用8.x的资源,便于安装时采用这个而不是yum自己原来的远程仓,不知道这个解释对不对。

我反复试过了,命令明明提示请执行 sudo yum -y install nodejs 来安装nodejs8.x,却一直安装的是6.x,难道是依赖问题?找不出原因的我,没有办法只能找其他安装途径,于是发现了第二种安装办法,手动获取最新的安装包,并进行解压缩安装,可能依赖Python2.7以上版本,我一步步来说。

如果是仅手动安装Nodejs8.x,执行以下命令:

yum install gcc-c++ openssl-devel
cd /usr/local/src
wget http://nodejs.org/dist/v8.9.4/node-v8.9.4.tar.gz
tar zxvf node-v8.9.4.tar.gz
(cd into extracted folder: ex "cd node-v8.9.4.tar.gz")
./configure
make
make install

顺利的话应该不会有什么问题,大概会过一段时间,稍微有点长,就提示安装好了,可以执行

node -v

来查看是否是8.x,如果好了,基本上关于安装部分就大功告成了。如果没好,太惨了,跟Python有关系的话,请查看Linux下Python安装升级心得

接着我们来看看删除,因为你已经安装了一个低版本,需要升级,那就是要先删除旧版本了,nodejs应该是向下兼容的,所以我就没有去研究可能闲着蛋疼才会去研究如果保存多个版本nodejs,当然在新版中可能会存在部分旧的功能废除而造成异常,虽然一般来说升级利大于弊,不过还是要考虑老项目环境是否要升级!如果你是闲着蛋疼的人,必有理由说服我,请在下方留言。差点跑题,删除命令简直是太简单了。

sudo yum remove nodejs

然后按提示输入y,回车后很快就删了。一切删除操作都是令人兴奋的。。。

其实,我在安装过程中远没有那么轻松,否则也不会折腾几天了,一个是版本错误,一个是Python升级。版本问题,后来差了很多资料才发现,原来是yum缓存问题导致。如果遇到和我类似的问题,请尝试以下命令:

rm -f /etc/yum.repos.d/nodesource-el.repo
yum clean all
yum -y remove nodejs
yum -y install nodejs

汇总下本文参阅的相关文章:

  1. Nodejs官方文档,通过包管理安装Nodejs
  2. Centos下手动安装Nodejs的方法
  3. 无法在Yum仓下安装正确的Nodejs版本(和刚才示例的代码类似,都是清除缓存,不过对我无效)
  4. CentOS下使用nodejs7.x的包进行安装却安装成了6.9.5(针对我的有效方案)
  5. 如何通过Linux命令删除Nodejs

所以我呢,其实就是应该遇到版本不对的情况就尝试清除缓存,再用官方命令进行安装就好了~

我想既然是Yum仓库缓存的问题,除了Nodejs,别的包也许也会有类似情况吧,如果也发现了选择了需要的版本后依然装的是旧版的,又和依赖没什么关系,就试试清除缓存吧 🙂

购买VPS后折腾小记

近日购买了个美国的VPS,为了愉快的查阅资料和关注一些不错的视频,搭了个梯子,自己种番茄,也从此走上了不归路,这是我近期玩VPS的一点点小感想~

由于多次购买番茄烂了,老板跑路,损失几百。于是决定自己搭架子种番茄。正巧碰上小熊前不久买了个VPS,简单看了下,还不错,关键是性价比极高,二话不说就买了。

按照服务器商家的购买流程,首选了Ubuntu 16.04系统,其实之前对VPS一无所知,也不知道是纯命令界面。读大学的时候就装过Ubuntu 10.xx不过那时候完全是好奇尝新,也没学到个啥。

购买完了,后台给了个IP,研究了下,就想着怎么折腾,不过这个后台太简单了吧,只有reboot,boot,shutdown和完全不知道干啥用的console什么的,去查了下,也没看懂,就先不管了。

此刻的我面对这个VPS后台,心想怎么操作呢= =,只玩过虚拟主机的我,感觉像是乡下来的土鳖,翻遍了整个服务商提供的页面,也没找到个什么所以然。只得百度一下VPS怎么玩,才知道原来一般来说只有SSH连接工具连接,纯命令操作。。。此刻一脸懵逼的我,下了个XShell,因为看到是共享软件,就去找了个绿色破解版,至此走上不归路。。。

其实刚开始用这个破解版的XShell都挺好,连接上了后,安装番茄工具,简单配置,一切顺利,晚上测了一下速度,棒棒哒,美滋滋。第一天夜晚很顺利,我就安心的睡了。直到第二天。。。

早上,想测测番茄发育良好不。发现咋突然烂了- -。这一晚上就挂了,然后开机发现服务器Offline了。怎么就无缘无故Offline了呢,手动Boot一下,好了,可是没过半分钟,又Offline了。完全无法正常使用,然后开始了一天ticket和客服对话中,很糟糕的客服体验,折磨了我两天,后来才知道,服务器遭到DDOS攻击,流量一晚上偷跑30多G,而且带宽只要一连接就处于满载状态,VPS自动进入休眠策略,这可咋办,我想利用每次连接不到1分钟的时间来搞防火墙等安全措施,基本上都失败了,一方面对网络安全不是很懂,另一方面也不熟悉Linux系统的相关命令,在纯命令行模式下操作对我来说是极大的挑战。所以对于这次DDOS攻击的防御战中,我是彻底失败了。最后和效率极低的客服终于沟通完了,重装了CentOS系统。之所以沟通很费劲,是因为客服回复效率超低,每次等1-3小时不等,而且他们没有给后台权限,就是用户自主决定重装系统的权限,他们有两个后台,以为我有,我其实没有,所以根本没法重装,就这样一脸懵逼的郁闷到了第三天。

Control Panel Permission Accessed Day简直爽歪歪,重装系统后,SSH操作也顺利得多了。不过好不容易搞明白apt-get,现在又来个yum,虽然差不多- -又开始折腾CentOS的路上,种番茄依赖Python等,然后还有各种版本的Python,网上资料大部分写的不够细致,或者不适合我的环境,经常在操作的过程中发生各种异常情况,结果系统似乎被我搞得一团糟。总结了流程和相关要点后,我再次重装了系统,采用了傻瓜式一键安装包。。。简直傻瓜得不能再傻瓜了,半小时不到就搞好了- -,看来我这种小白还是适合一键安装 😕

之后我的番茄地很稳定,没有什么异形攻击,除了我自己时不时在研究iptables和netstat命令以及kill -s搞毁了之外。。。

在之后,闲着无聊就测速。由于是OpenVZ构架的VPS,我又开始琢磨怎么加速,什么BBR加速之类的,又看了好多教程资料。鼓捣了一阵子,其实到底有没有效果我还真的没有确切的答案。反正差不多就这样了。

这几天又研究搞nodejs环境打网站了。。。感觉这几天玩VPS虽然有很多坑,但是还是挺开心的。还学会了不少Linux的操作,VIM操作(以前就知道vim觉得简直反人类,现在稍微用了下虽然还是感觉很反人类,但似乎感觉也挺有趣~)

由于Windows相关操作都很坑爹,比如ssh连接上就是让我掉进坑了,也算是我图省事,后来推测那个破解版的XShell估计有后门,所以连上后就被控制了。后来重装系统后我用了免费的PuTTy,其实这个足够使用了。

还有后来我试着部署一个博客系统Jekyll,windows下也是失败了,太繁琐,太麻烦了,linux上面则容易得多。突然有想买MacBook的冲动,不过穷战胜了我的欲望。我想了两天后就不想了。。。

还有什么没有提到的,大概就这些吧,这篇纯属是日记,所以也就没什么条理了~

 

PostCSS学习指南(二)

关于我最近学习PostCSS的一些相关心得和总结,主要介绍项目中可能用到的一些插件比如autoprefixer,postcss-partial-import,postcss-advanced-variables,cssnano,postcss-px2rem,precss等等

(推荐访问github上面的Markdown排版的介绍PostCSS学习指南(二))

继上一次PostCSS学习指南(一)后,渐渐开始在项目中应用。

这次决定主要讲解一些个人认为非常有帮助的PostCSS插件。

本期主要介绍以下几个插件和几个坑

  1. autoprefixer
  2. postcss-partial-import
  3. postcss-advanced-variables
  4. cssnano
  5. postcss-px2rem
  6. precss
  7. postcss-nestingpostcss-nested
  8. 坑( ఠൠఠ )ノ

autoprefixer

这个就不用多说了,必装插件之一。方便的写规范的css,它会为你提供非常完整的hack兼容方案的。当然这里需要了解一下的是,它的大部分兼容数据来源Can I Use,另外一个稍微需要了解的插件配置参数就是browsers,比如这样写:

module.exports = {
  plugins: [
    require('autoprefixer')({ browsers: 'last 2 versions' })
  ]
}

关于这个参数的详细介绍可以看看Browserslist Queries,文中说了,强烈建议将查询写入package.json(后面会告诉你为何要写在这里),而非配置postcss.config.js中autoprefixer的browsers参数。所以此处建议写法如下: 继续阅读“PostCSS学习指南(二)”

为了WordPress支持markdown…我重装了wordpress和theme,然而…

为了让wordpress支持markdown,重新升级了后台和主题还是没能像官方说明那样解决…最后才发现,那是给基于wordpress官方站点上创建的博客使用的…也真是醉了.

随着时代的推移,大部分文档开始使用markdown格式来编写了…我也打算把这些我排版好的markdown格式的文件直接弄到wordpress上面发表…我Google了一下,第一篇就是这篇文章Markdown — Support.

满怀欣喜的按照里面的说明找到设置 – 撰写, 却没有看到那个开启markdown的选项.

我有点不爽,难道是版本过低.对于每次进入后台都看到升级提示已经令我很不爽了…好吧我更新一下吧.折腾了大半天更新完了…也就是现在看到的博客的新样子…有2015主题换成了2016主题,本来想2017的,完全不懂头部的那张大图的设计含义…小心翼翼的保证一切主题修改的没出错(其实我也不知道到底出错没).主要是插件,主题的部分php修改,还有自己添加的代码高亮组件.反正瞎倒腾好了…再次满怀欣喜的找到设置-撰写发现根本就跟之前一样的时候…

我觉得我经历了绝望.这什么破玩意哦…遂去查找有没有相关的Markdown插件,貌似也没一个比较好用的…

这次大的更新,就当作是升级了一下…找了很多为什么没有刚才那个选项,后来说只有在他们服务器上面开的wordpress站点才支持,并非wordpress这个程序支持…于是我在我在wordpress上面创建的博客后台找到了…真是坑爹.

wordpress是不支持markdown的
wordpress是不支持markdown的

好吧,至此,如果实在是要的话,就只能用插件了…我不太想装插件,勉强就先这样了.如果你需要的话,据说比较好用的就是Jetpack了,大家自己尝试下下咯~

参考:

How to use markdown for wordpress posts

在Wordpress中如何使用MarkDown编辑博文?

页面内某元素到文档顶部的距离计算

之前写了一篇元素到网页顶部距离计算方法,其实分明有更好的方法,例如这个方法就不需要写那么复杂的循环了,这里再次总结一下。

2015年1月7日

之前写了一篇元素到网页顶部距离计算方法,其实分明有更好的方法,例如这个方法就不需要写那么复杂的循环了,这里再次总结一下。

请看下面代码,或者查看在线demo调试,看起来兼容性都是OK的。大家可以自己试试。

<html lang="en">
<head>
    <meta charset="UTF-8">
    <title>the distance to top</title>
    <style type="text/css">
    div {margin:10px 20px;padding:5px;border:3px solid #aaa;position:relative;}
    .para {background-color:#ccc;}
    </style>
</head>
<body>
<div class="outer">
    <div class="outerWrap">
        <div class="header"></div>
        <div class="content">
            <div class="content-inner">
                <p class="para" id="para">
                    Hello, whidy! 这是一个获取当前元素距离网页顶部高度的计算demo.
                </p>
            </div>
        </div>
    </div>
</div>
<script type="text/javascript">
para = document.getElementById('para');
var y = para.offsetTop;
var y2 = para.getBoundingClientRect().top;
while (para = para.offsetParent) {
    var oStyle = para.currentStyle? para.currentStyle : window.getComputedStyle(para, null); //currentStyle兼容IE
    var borderTopWidth = parseInt(oStyle.getPropertyValue('border-top-width')); //border-top-width实际上用于被包父级层的边框值计算,因此本demo内header的边框值对此处不影响,取而代之的是直接计入content盒子距离outerWrap的高度
    if(borderTopWidth) { //如果有边框值则加上边框
        y += para.offsetTop + borderTopWidth;
    }
    console.log(y,'offsetTop');
    console.log(y2,'getBoundingClientRect');
}
</script>
</body>
</html>

参考资料: Element.getBoundingClientRect() – Web API 接口 | MDN